Proxmox VE 6.4 est disponible avec OpenZFS 2.0.4 et restauration simplifiée

Proxmox VE 6.4 est disponible avec OpenZFS 2.0.4 et restauration simplifiée

Il est temps de virtualiser !

Avatar de l'auteur
David Legrand

Publié dans

Hardware

28/04/2021 2 minutes
11

Proxmox VE 6.4 est disponible avec OpenZFS 2.0.4 et restauration simplifiée

OpenZFS est disponible depuis peu, Proxmox a donc décidé de l'intégrer pour la première fois au sein de son hyperviseur VE qui passe en version 6.4 pour l'occasion. D'autres améliorations sont au programme, notamment sur les procédures de restauration.

Proxmox continue de mettre à jour ses différentes solutions. Après la version 1.1 de Backup Server, l'hyperviseur Virtual Environment (VE) passe à la 6.4. Elle est basée sur Debian 10.9 avec un noyau 5.4 (le 5.11 étant proposé en option). Les différents composants ont aussi été améliorés : Ceph Octopus 15.2.11 et Nautilus 14.2.20, LXC 4.0, QEMU 5.2 et ZFS 2.0.4. Dans ce dernier cas, il s'agit d'une évolution majeure puisque la précédente était la 0.8.5. 

L'équipe met principalement en avant une évolution des procédures de restauration, devant aider à réduire le temps de retour à la normale en cas de problème. Deux sont proposées : Single-File Restore ou Live Restore. Dans le premier cas, il s'agit de récupérer un fichier unique depuis la sauvegarde d'une machine virtuelle (VM) ou d'un conteneur.

La seconde procédure nécessite d'utiliser Backup Server et consiste à restaurer la VM au plus vite pour qu'elle puisse démarrer, puis de s'occuper des données les moins utilisées en arrière-plan. 

Les notes de version évoquent également de nombreuses petites améliorations et autres corrections de bugs. La documentation complète se trouve ici. Une vidéo de présentation des nouveautés est également proposée :

Écrit par David Legrand

Tiens, en parlant de ça :

Sommaire de l'article

Introduction

Fermer

Commentaires (11)


Je commence sur Proxmox, Question en étant en 6.3. la migration sera automatique ou je dois me réinstaller mon homelab ?


Dans la documentation c’est juste indiqué via apt.



(reply:56835:Fab’z)




OK merci pour l’info, si jamais ça ne fonctionne pas avec le dist-upgrade
Je vérifierai comment ont été mis à jour mes fichier de conf des dépots étant sur la version sans souscription avec modif manuelle pour éliminer le message de non souscription.


Testé rapidement, la restauration de fichier unique ne supporte pas tous les type de partition (LVM) et de système de fichiers. A priori le support va s’étendre au fil des mises à jour.



En tout cas avec le backup server, pour peut qu’on fasse attention à ses config de VM ça commence à devenir suffisamment confortable niveau sauvegarde pour ne plus avoir a ajouter une solution tiers.



samyfox16 a dit:


OK merci pour l’info, si jamais ça ne fonctionne pas avec le dist-upgrade Je vérifierai comment ont été mis à jour mes fichier de conf des dépots étant sur la version sans souscription avec modif manuelle pour éliminer le message de non souscription.




Le message de non souscription est revenu mais sinon l’upgrade est passé comme une lettre à la poste
Je suis passé par l’interface graphique pour l’upgrade au lieu de la console (j’ai honte :-).



J’installerai la nouvelle version de proxmox backup (avec la nouveauté sur le système de restauration) un peu plus tard en tout cas les VM de test sont toutes opérationnelles.



Rien à faire apparemment au niveau des agents de VM comme sur d’autres système de virtualisation.



samyfox16 a dit:


Je commence sur Proxmox, Question en étant en 6.3. la migration sera automatique ou je dois me réinstaller mon homelab ?




Ce sont juste les versions majeures qui sont un peu délicates à mettre à jour, car cela veut dire (en général) une montée en version de la distribution Debian sur laquelle est bâtie Proxmox. (Pour avoir fait de la montée de version de VSphere, c’est folklo aussi même pour les mineures, voire c’est purement impossible car non supporté par le serveur…)


Les mises à jour de version mineures passent comme une lettre à la poste.
Mais je le déploie d’abord sur le cluster de test avant de les lancer sur celui de prod.
Jusqu’ici, aucun problème rencontré. Depuis 18 mois, sur grappe Ceph HA


Après les produits VMWare c’est vraiment pas le top niveau stabilité. J’ai toujours trouvé honteux la qualité de leur système (qui est très loin d’être gratuit…).


Il faudrait peut être arrêter de faire du vsphere sur du matos pourri. Vmware est un monstre qui justifie largement son prix.


Jusqu’ici je n’ai eu qu’un seul problème avec VMWare. J’arrive à faire crasher ESXi 6.5 sur un Proliant DL360 G9 simplement en mettant à jour un OPNSense via GUI depuis un PC HP recyclé dans le même réseau. Je sais pas s’il y a du bug bounty à se faire… mais j’ai jamais compris le pourquoi du comment. :zarb:



patos a dit:


Il faudrait peut être arrêter de faire du vsphere sur du matos pourri. Vmware est un monstre qui justifie largement son prix.




Si tu considères un matos tout pourri, un matos qui était supporté correctement par vSphere en version V - 0.5… Proxmox te prend clairement moins pour un portefeuille sur patte ;-)